*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytidylib / pytidylib-0.2.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
11 HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="app-text/htmltidy"
21 DEPEND="${RDEPEND}
22         test? ( dev-python/pytest )"
23
24 python_test() {
25         py.test -vv || die
26 }