*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pythonz-bd / pythonz-bd-1.11.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7}} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Manage python installations in your system, berdario's shallow fork"
11 HOMEPAGE="
12         https://github.com/berdario/pythonz/tree/bd
13         https://pypi.org/project/pythonz-bd/"
14 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
19 IUSE=""
20
21 RDEPEND=""
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         $(python_gen_cond_dep 'dev-python/resumable-urlretrieve[${PYTHON_USEDEP}]' 'python3*')"