*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-zaqarclient / python-zaqarclient-1.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A client for the OpenStack Zaqar API"
10 HOMEPAGE="https://github.com/openstack/python-zaqarclient"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
16
17 CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         ${CDEPEND}"
20 RDEPEND="
21         ${CDEPEND}
22         >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
23         >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
24         >=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
25         >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
26         !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
27         <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
28         >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
29         >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
30         >=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}]
31         !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
32         >=dev-python/osc-lib-1.0.2[${PYTHON_USEDEP}]
33 "
34
35 python_prepare_all() {
36         # built in...
37         sed -i '/^hacking/d' test-requirements.txt || die
38         distutils-r1_python_prepare_all
39 }