*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-varlink / python-varlink-29.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python implementation of the Varlink protocol"
11 HOMEPAGE="https://github.com/varlink/python"
12 SRC_URI="https://github.com/varlink/python/archive/${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="Apache-2.0"
14 SLOT="0"
15
16 KEYWORDS="~amd64"
17 RESTRICT="test"
18 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         dev-python/future[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}"
21 S="${WORKDIR}/python-${PV}"
22
23 python_test() {
24         esetup.py test || die "tests failed with ${EPYTHON}"
25 }