*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / python-urljr / python-urljr-1.0.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="JanRain's URL Utilities"
10 HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
11 SRC_URI="http://www.openidenabled.com/resources/downloads/python-openid/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="curl test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="curl? ( >=dev-python/pycurl-7.15.1[${PYTHON_USEDEP}] )"
20 DEPEND=""
21
22 REQUIRED_USE="test? ( curl )"
23 # test fails if it finds 'localhost' instead of '127.0.0.1'
24 PATCHES=( "${FILESDIR}/${P}-gentoo-test_fetchers.patch" )
25
26 python_test() {
27         PYTHONPATH=. "${PYTHON}" admin/runtests || die "tests failed"
28 }