*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-twitter / python-twitter-3.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python wrapper around the Twitter API"
11 HOMEPAGE="https://github.com/bear/python-twitter"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~x86-macos"
17 IUSE="examples"
18
19 RDEPEND="
20         dev-python/oauth2[${PYTHON_USEDEP}]
21         dev-python/simplejson[${PYTHON_USEDEP}]
22         dev-python/requests[${PYTHON_USEDEP}]
23         dev-python/requests-oauthlib[${PYTHON_USEDEP}]"
24
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
26
27 # Testsuite is still not convincing in its completeness
28 RESTRICT="test"
29
30 src_prepare() {
31         distutils-r1_src_prepare
32 }
33
34 # https://code.google.com/p/python-twitter/issues/detail?id=259&thanks=259&ts=1400334214
35 python_test() {
36         esetup.py test
37 }