*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-sense-hat / python-sense-hat-2.2.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Raspberry Pi Sense HAT python library"
11 HOMEPAGE="https://github.com/RPi-Distro/python-sense-hat"
12 SRC_URI="https://github.com/RPi-Distro/python-sense-hat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="arm arm64"
17
18 RDEPEND="
19         dev-python/numpy[${PYTHON_USEDEP}]
20         dev-python/pillow[${PYTHON_USEDEP}]
21         dev-python/rtimulib[${PYTHON_USEDEP}]
22 "
23
24 DEPEND="${RDEPEND}"
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"