*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-poppler-qt5 / python-poppler-qt5-0.24.2_p20170214.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7 COMMIT=50fb2eb9ea34cf94e3756b7ddfc601af023267d5
8 inherit distutils-r1 flag-o-matic qmake-utils vcs-snapshot
9
10 DESCRIPTION="A python binding for libpoppler-qt5"
11 HOMEPAGE="https://github.com/wbsoft/python-poppler-qt5"
12 SRC_URI="https://github.com/wbsoft/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 RDEPEND="
20         app-text/poppler[qt5]
21         dev-python/PyQt5[${PYTHON_USEDEP}]
22         >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}"
25
26 python_configure_all() {
27         append-cxxflags -std=c++11
28         mydistutilsargs=( build_ext --qmake-bin=$(qt5_get_bindir)/qmake )
29 }