*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-podman / python-podman-0.12.1.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A library for communicating with a Podman server"
11 HOMEPAGE="https://github.com/containers/libpod/tree/master/contrib/python/podman/"
12 SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> libpod-${PV}.tar.gz"
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64"
16
17 RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
18         dev-python/python-dateutil[${PYTHON_USEDEP}]
19         dev-python/python-varlink[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         >=dev-python/setuptools-39[${PYTHON_USEDEP}]"
22 RESTRICT="test"
23 S="${WORKDIR}/libpod-${PV}/contrib/python/podman"
24
25 python_test() {
26         esetup.py test || die "tests failed with ${EPYTHON}"
27 }