*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / python-lzo / python-lzo-1.12.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6} )
7
8 inherit distutils-r1 prefix
9
10 DESCRIPTION="Python interface to lzo"
11 HOMEPAGE="https://github.com/jd-boyd/python-lzo"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-libs/lzo:2"
22
23 DEPEND="
24         ${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         test? ( dev-python/nose[${PYTHON_USEDEP}] )"
27
28 src_prepare() {
29         distutils-r1_src_prepare
30         hprefixify setup.py
31 }
32
33 python_test() {
34         distutils_install_for_testing
35         PYTHONPATH="${TEST_DIR}"/lib nosetests -v || die "tests failed"
36 }