*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-ethtool / python-ethtool-0.14.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 # TODO: install scripts and their man pages
9
10 inherit distutils-r1
11
12 DESCRIPTION="Ethernet settings python bindings"
13 HOMEPAGE="https://pypi.org/project/ethtool/
14         https://github.com/fedora-python/python-ethtool"
15 SRC_URI="https://github.com/fedora-python/python-ethtool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64"
20
21 DEPEND="dev-libs/libnl:3"
22 RDEPEND="${DEPEND}"
23 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
24
25 PATCHES=( "${FILESDIR}"/test-skip-wg-dev.patch )
26
27 python_test() {
28         esetup.py test || die "Tests failed with ${EPYTHON}"
29 }