*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / python-etcd / python-etcd-0.4.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A python client for etcd"
11 HOMEPAGE="https://github.com/jplana/python-etcd https://pypi.org/project/python-etcd/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-python/dnspython[${PYTHON_USEDEP}]
21         >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
22         >=dev-python/urllib3-1.7.1[${PYTHON_USEDEP}]"
23
24 DEPEND="${RDEPEND}
25         test? (
26                 dev-db/etcd
27                 dev-python/mock[${PYTHON_USEDEP}]
28                 dev-python/nose[${PYTHON_USEDEP}]
29         )"
30
31 python_test() {
32         esetup.py test
33 }