07b6df7b2dc82557fc3900ea58ba683c641a0bc9
[gentoo.git] / dev-python / python-docs / python-docs-3.7.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="HTML documentation for Python"
7 HOMEPAGE="https://www.python.org/doc/"
8 SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
9 S="${WORKDIR}/python-${PV}-docs-html"
10
11 LICENSE="PSF-2"
12 SLOT="$(ver_cut 1-2)"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86"
14
15 src_install() {
16         rm -r _sources || die
17         docinto html
18         dodoc -r .
19
20         newenvd - 60python-docs-${SLOT} <<-EOF
21                 PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
22         EOF
23 }