*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-ctags / python-ctags-1.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
7
8 inherit distutils-r1
9
10 MY_PN="${PN}3"
11 DESCRIPTION="Exuberant Ctags indexing python bindings"
12 HOMEPAGE="https://github.com/jonashaag/python-ctags3"
13 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
14
15 LICENSE="LGPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18
19 RDEPEND="dev-util/ctags"
20 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21
22 S="${WORKDIR}/${MY_PN}-${PV}"
23
24 python_test() {
25         esetup.py test
26 }