*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / python-augeas / python-augeas-0.5.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python bindings for Augeas"
11 HOMEPAGE="http://augeas.net/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17 IUSE=""
18
19 DEPEND="app-admin/augeas"
20 RDEPEND="${DEPEND}"
21
22 DOCS="AUTHORS README.txt"
23
24 python_test() {
25         cd test || die
26         "${PYTHON}" test_augeas.py || die
27 }