*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytest-timeout / pytest-timeout-1.3.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="py.test plugin to abort hanging tests"
11 HOMEPAGE="https://pypi.org/project/pytest-timeout/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="amd64 ~arm arm64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
17
18 RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
19 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 PATCHES=(
22         "${FILESDIR}/pytest-timeout-1.3.3-tests.patch"
23 )
24
25 python_test() {
26         distutils_install_for_testing
27
28         pytest -vv || die "Tests fail with ${EPYTHON}"
29 }