*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytest-testmon / pytest-testmon-0.9.15.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit distutils-r1
8
9 DESCRIPTION="take TDD to a new level with py.test and testmon"
10 HOMEPAGE="https://github.com/tarpas/pytest-testmon"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
20 dev-python/coverage[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]"
23
24 python_test() {
25         distutils_install_for_testing
26         py.test -v || die "Tests fail with ${EPYTHON}"
27 }