*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytest-pep8 / pytest-pep8-1.0.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="pytest plugin to check PEP8 requirements"
11 HOMEPAGE="https://pypi.org/project/pytest-pep8/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="~amd64 ~arm64 ~x86"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         >=dev-python/pep8-1.3[${PYTHON_USEDEP}]
22         >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
23         dev-python/pytest-cache[${PYTHON_USEDEP}]
24 "
25 DEPEND="${RDEPEND}"
26
27 PATCHES=(
28         "${FILESDIR}"/1.0.6-MANIFEST.patch
29 )
30
31 python_test() {
32         ${EPYTHON} test_pep8.py || die
33 }