*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytest-metadata / pytest-metadata-1.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A plugin for pytest that provides access to test session metadata"
10 HOMEPAGE="https://github.com/pytest-dev/pytest-metadata/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MPL-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17 RDEPEND=">=dev-python/pytest-3.0[${PYTHON_USEDEP}]"
18 DEPEND="${RDEPEND}
19         dev-python/setuptools[${PYTHON_USEDEP}]
20         dev-python/setuptools_scm[${PYTHON_USEDEP}]"
21
22 python_test() {
23         py.test || die
24 }