*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytest-localserver / pytest-localserver-0.3.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=(python{2_7,3_6,3_7})
6
7 inherit distutils-r1
8
9 DESCRIPTION="Py.test plugin to test server connections locally"
10 HOMEPAGE="https://pypi.org/project/pytest-localserver/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~arm64 x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
20 DEPEND="test? ( ${RDEPEND}
21                 dev-python/pytest[${PYTHON_USEDEP}]
22                 dev-python/requests[${PYTHON_USEDEP}]
23                 dev-python/six[${PYTHON_USEDEP}] )"
24
25 python_test() {
26         py.test -v || die
27 }