*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytest-isort / pytest-isort-0.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="py.test plugin for isort"
11 HOMEPAGE="https://github.com/moccu/${PN} https://pypi.python.org/pypi/${PN}"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
17 IUSE=""
18
19 RDEPEND="
20         >=dev-python/isort-4.0[${PYTHON_USEDEP}]
21         >=dev-python/pytest-3.5[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25 "
26
27 python_test() {
28         py.test -vs --cache-clear || die "testsuite failed under ${EPYTHON}"
29 }