*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pytest-cache / pytest-cache-1.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="mechanisms for caching across test runs"
11 HOMEPAGE="https://pypi.org/project/pytest-cache/
12         https://bitbucket.org/hpk42/pytest-cache/
13         https://pythonhosted.org/pytest-cache/"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15
16 SLOT="0"
17 LICENSE="MIT"
18 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
19 IUSE="test"
20
21 RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? ( dev-python/pytest[${PYTHON_USEDEP}] )
25         "
26
27 # https://bitbucket.org/hpk42/pytest-cache/issues/12
28 RESTRICT=test
29
30 python_test() {
31         PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
32 }