*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pysendfile / pysendfile-2.0.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A python interface to the sendfile(2) system call"
11 HOMEPAGE="https://github.com/giampaolo/pysendfile"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 sparc x86"
15 IUSE=""
16 LICENSE="MIT"
17 SLOT="0"
18
19 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 python_test() {
22         "${EPYTHON}" test/test_sendfile.py || die "tests failed with ${EPYTHON}"
23 }