*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyrfc3339 / pyrfc3339-1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=(python{2_7,3_6,3_7})
6
7 inherit distutils-r1
8 MY_PN=pyRFC3339
9
10 MY_P=${MY_PN}-${PV}
11 DESCRIPTION="Generates and parses RFC 3339 timestamps"
12 HOMEPAGE="https://github.com/kurtraschke/pyRFC3339"
13 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
22 DEPEND="test? ( ${RDEPEND}
23                 dev-python/nose[${PYTHON_USEDEP}] )
24         dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 S=${WORKDIR}/${MY_P}
27
28 python_test() {
29         nosetests || die
30 }