*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pypcap / pypcap-1.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6 inherit distutils-r1
7
8 DESCRIPTION="Simplified object-oriented Python extension module for libpcap"
9 HOMEPAGE="https://github.com/pynetwork/pypcap https://pypi.org/project/pypcap/"
10 SRC_URI="https://github.com/pynetwork/pypcap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND="
17         net-libs/libpcap
18 "
19 DEPEND="
20         ${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]
22 "
23 PATCHES=(
24         "${FILESDIR}"/${PN}-1.1.6-mktemp.patch
25 )
26
27 python_compile() {
28         local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
29         distutils-r1_python_compile
30 }