*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyparted / pyparted-3.11.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_6} )
6 inherit distutils-r1
7
8 DESCRIPTION="Python bindings for sys-block/parted"
9 HOMEPAGE="https://github.com/rhinstaller/pyparted/"
10 SRC_URI="${HOMEPAGE}archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17 REQUIRED_USE="
18         test? ( python_targets_python2_7 )
19 "
20
21 RDEPEND="
22         >=sys-block/parted-3.1
23         dev-python/decorator[${PYTHON_USEDEP}]
24 "
25 DEPEND="
26         ${RDEPEND}
27         virtual/pkgconfig
28 "
29
30 PATCHES=(
31         "${FILESDIR}"/${PN}-3.10.3-greater.patch
32 )
33
34 python_test() {
35         emake test
36 }