*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pymysql / pymysql-0.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 MY_PN="PyMySQL"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Pure-Python MySQL Driver"
14 HOMEPAGE="https://github.com/PyMySQL/PyMySQL"
15 SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~arm64 ~x86"
20 IUSE="test"
21
22 S=${WORKDIR}/${MY_P}
23
24 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 # While tests exist, they require an unsecure server to run without manual config file
27 RESTRICT="test"
28
29 python_test() {
30         ${PYTHON} runtests.py || die
31 }