*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyminuit / pyminuit-1.2.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1 flag-o-matic
9
10 DESCRIPTION="Minuit numerical function minimization in Python"
11 HOMEPAGE="https://github.com/jpivarski/pyminuit"
12 SRC_URI="
13         https://pyminuit.googlecode.com/files/${P}.tgz
14         https://pyminuit.googlecode.com/files/Minuit-1_7_9-patch1.tar.gz
15         "
16
17 SLOT="0"
18 LICENSE="GPL-2"
19 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
20 IUSE=""
21
22 S="${WORKDIR}"/${PN}
23
24 src_configure() {
25         cd "${WORKDIR}"/Minuit-1_7_9 || die
26         econf --disable-static
27 }
28
29 src_compile() {
30         cd "${WORKDIR}"/Minuit-1_7_9 || die
31         emake
32         cd "${S}" || die
33         distutils-r1_src_compile
34 }
35
36 python_install_all() {
37         cd "${WORKDIR}"/Minuit-1_7_9 || die
38         default
39         distutils-r1_python_install_all
40 }