*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyicu / pyicu-2.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 MY_PN="PyICU"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Python bindings for dev-libs/icu"
14 HOMEPAGE="https://github.com/ovalhub/pyicu"
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="test"
21
22 RESTRICT="!test? ( test )"
23
24 RDEPEND="${PYTHON_DEPS}
25         dev-libs/icu:="
26 DEPEND="${RDEPEND}
27         test? ( dev-python/pytest
28                 dev-python/six )"
29
30 S="${WORKDIR}/${MY_P}"
31
32 DOCS=(CHANGES CREDITS README.md)
33
34 # This will no longer be necessary in the next release
35 PATCHES=( "${FILESDIR}"/${PN}-2.3.1-testSurrogatePairs_workaround.patch )
36
37 python_test() {
38         esetup.py test
39 }