*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyhcl / pyhcl-0.2.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="HCL configuration parser for python"
11 HOMEPAGE="https://github.com/virtuald/pyhcl"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MPL-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=">=dev-python/ply-3.4[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
23
24 python_prepare_all() {
25         sed -i -e "s/==.*$//" requirements.txt || die
26         distutils-r1_python_prepare_all
27 }
28
29 python_test() {
30         py.test -v || die
31 }