*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pygsl / pygsl-2.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python interface for the GNU scientific library (gsl)"
11 HOMEPAGE="http://pygsl.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="GPL-2"
16 KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
17 IUSE="examples"
18
19 DEPEND="
20         <sci-libs/gsl-2
21         dev-python/numpy[${PYTHON_USEDEP}]"
22 RDEPEND="${DEPEND}"
23 # Testsuite written to be run post install
24
25 python_install_all() {
26         use examples && dodoc -r examples
27         distutils-r1_python_install_all
28 }