*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pygit2 / pygit2-0.28.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit distutils-r1 eapi7-ver
8
9 DESCRIPTION="Python bindings for libgit2"
10 HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2-with-linking-exception"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="
20         =dev-libs/libgit2-$(ver_cut 1-2)*
21         >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
22         dev-python/six[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
26
27 src_prepare() {
28         distutils-r1_src_prepare
29
30         # we need to move them away to prevent pytest from forcing '..'
31         # for imports
32         mkdir hack || die
33         mv test hack/ || die
34         ln -s hack/test test || die
35 }
36
37 python_test() {
38         pytest -vv hack/test || die
39 }