182349d5178173596a0732ec16cebd8bf8859211
[gentoo.git] / dev-python / pyflakes / pyflakes-1.0.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Passive checker for Python programs"
10 HOMEPAGE="https://launchpad.net/pyflakes https://pypi.org/project/pyflakes/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND="${DEPEND}"
20
21 PATCHES=( "${FILESDIR}"/${PV}-fix-pypy-tests.patch )
22
23 python_test() {
24         esetup.py test --quiet
25 }