*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyfeyn / pyfeyn-1.0.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python package for drawing Feynman diagrams"
10 HOMEPAGE="http://pyfeyn.hepforge.org/ https://pypi.org/project/pyfeyn/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="latex"
17
18 DEPEND=""
19 RDEPEND=">=dev-python/pyx-0.14[${PYTHON_USEDEP}]
20         latex? ( dev-texlive/texlive-mathscience )"
21
22 PATCHES=( "${FILESDIR}"/${P}.patch )