*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyfakefs / pyfakefs-3.5.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
6 DISTUTILS_IN_SOURCE_BUILD=1
7
8 inherit distutils-r1
9
10 DESCRIPTION="a fake file system that mocks the Python file system modules"
11 HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
12 SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21 RDEPEND="${COMMON_DEPEND}"
22 DEPEND="${COMMON_DEPEND}
23         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
24
25 PATCHES=( "${FILESDIR}"/pyfakefs-3.4.3-tests.patch )
26
27 python_test() {
28         "${PYTHON}" -m ${PN}.tests.all_tests || die "tests failed under ${EPYTHON}"
29 }