*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / pyenchant / pyenchant-1.6.8.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python bindings for the Enchant spellchecking system"
11 HOMEPAGE="http://pyenchant.sourceforge.net https://pypi.org/project/pyenchant/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=">=app-text/enchant-${PV%.*}"
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( ${RDEPEND} )"
23
24 python_test() {
25         if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
26                 ewarn "Disabling tests due to missing en_US.UTF-8 locale"
27         else
28                 esetup.py test
29         fi
30 }