*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pydotplus / pydotplus-2.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Improved version of the old pydot project"
11 HOMEPAGE="http://pydotplus.readthedocs.org/"
12 SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 #       test? (
21 #               dev-python/flake8[${PYTHON_USEDEP}]
22 #               dev-python/pytest[${PYTHON_USEDEP}]
23 #               dev-python/pytest-cov[${PYTHON_USEDEP}]
24 #               dev-python/sphinx[${PYTHON_USEDEP}]
25 #               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
26 #               dev-python/tox[${PYTHON_USEDEP}]
27 #               )
28 RDEPEND="
29         dev-python/pyparsing[${PYTHON_USEDEP}]
30         "
31
32 #test phase curently disabled, waiting on upstream to include
33 #the required files:
34 #https://github.com/carlos-jenkins/pydotplus/issues/12
35 #python_test() {
36 #       ${EPYTHON} -m unittest discover || die
37 #       tox
38 #}