*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pydot / pydot-1.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python interface to Graphviz's Dot language"
10 HOMEPAGE="https://github.com/erocarrera/pydot https://pypi.org/project/pydot/"
11 # pypi releases don't include tests
12 SRC_URI="https://github.com/erocarrera/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         >=dev-python/pyparsing-2.1.4[${PYTHON_USEDEP}]
22         media-gfx/graphviz"
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
26
27 python_test() {
28         cd test || die
29         "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
30 }