*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pydecomp / pydecomp-0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7
8 inherit distutils-r1 python-r1
9
10 if [[ ${PV} == "9999" ]] ; then
11         EGIT_BRANCH="master"
12         EGIT_REPO_URI="https://github.com/dol-sen/pyDeComp.git"
13         inherit git-r3
14 else
15         SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
16         KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~riscv ~s390 ~sh sparc x86"
17         S="${WORKDIR}/pyDeComp-${PV}"
18 fi
19
20 DESCRIPTION="A python library of common (de)compression and contents handling"
21 HOMEPAGE="https://github.com/dol-sen/pyDeComp"
22
23 LICENSE="BSD"
24 SLOT="0"
25 IUSE=""
26
27 python_install_all() {
28         distutils-r1_python_install_all
29 }
30
31 pkg_postinst() {
32         einfo
33         einfo "Please file any enhancement requests, or bugs"
34         einfo "at https://github.com/dol-sen/pyDeComp/issues"
35         einfo "I am also on IRC @ #gentoo-releng of the freenode network"
36 }