*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pycryptodome / pycryptodome-3.7.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="A self-contained cryptographic library for Python"
12 HOMEPAGE="https://www.pycryptodome.org https://github.com/Legrandin/pycryptodome https://pypi.org/project/pycryptodome/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="BSD-2 Unlicense"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
18 IUSE=""
19
20 RDEPEND="dev-libs/gmp:0
21         virtual/python-cffi[${PYTHON_USEDEP}]
22         !dev-python/pycrypto"
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 python_test() {
27         esetup.py test
28 }