*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pycryptodome / pycryptodome-3.4.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="A self-contained cryptographic library for Python"
12 HOMEPAGE="https://github.com/Legrandin/pycryptodome"
13 SRC_URI="https://github.com/Legrandin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="BSD-2 Unlicense"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
18 IUSE=""
19
20 RDEPEND="dev-libs/gmp:0
21         virtual/python-cffi[${PYTHON_USEDEP}]
22         !dev-python/pycrypto"
23 DEPEND="${RDEPEND}"
24
25 python_test() {
26         esetup.py test
27 }