*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyasn1-modules / pyasn1-modules-0.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="pyasn1 modules"
11 HOMEPAGE="http://snmplabs.com/pyasn1/ https://github.com/etingof/pyasn1-modules/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=">=dev-python/pyasn1-0.4.1[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
24
25 python_test() {
26         esetup.py test
27 }
28
29 python_install_all() {
30         distutils-r1_python_install_all
31         insinto /usr/share/${P}
32         doins -r tools
33 }