*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyamg / pyamg-3.2.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Algebraic multigrid solvers in Python"
11 HOMEPAGE="https://pyamg.org"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/numpy[${PYTHON_USEDEP}]
22         sci-libs/scipy[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         test? ( dev-python/nose[${PYTHON_USEDEP}] )
26 "
27
28 python_test() {
29         distutils_install_for_testing
30         cd "${T}" || die # need to be away source directory
31         nosetests --verbose pyamg || die
32 }