*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyalsa / pyalsa-1.0.29.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )     # Still py2 only it appears
7
8 inherit distutils-r1 flag-o-matic
9
10 DESCRIPTION="Python bindings for ALSA library"
11 HOMEPAGE="https://alsa-project.org/"
12 SRC_URI="https://www.alsa-project.org/files/pub/pyalsa/${P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
17 IUSE=""
18
19 RDEPEND="media-libs/alsa-lib"
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]"
22
23 PATCHES=( "${FILESDIR}/${P}-no-build-symlinks.patch" )
24
25 python_configure_all() {
26         # note: this needs changing when py3 becomes supported
27         append-flags -fno-strict-aliasing
28 }
29 # Testsuite appears to require installed state