*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyTenable / pyTenable-0.3.19.ebuild
1 # Copyright 2018-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Tenable API Library for Tenable.io and SecurityCenter"
11 HOMEPAGE="https://github.com/tenable/pyTenable"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
22         dev-python/python-dateutil[${PYTHON_USEDEP}]
23         >=dev-python/requests-2.19[${PYTHON_USEDEP}]
24         >=dev-python/requests_pkcs12-1.3[${PYTHON_USEDEP}]
25         >=dev-python/semver-2.8.1[${PYTHON_USEDEP}]
26 "
27 DEPEND="${RDEPEND}"
28
29 # requires networking and API endpoint
30 RESTRICT="test"