*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / pyFFTW / pyFFTW-0.11.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7 inherit distutils-r1
8
9 DESCRIPTION="A pythonic python wrapper around FFTW"
10 HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
11
12 LICENSE="BSD"
13 SLOT="0"
14 if [ "${PV}" = "9999" ]; then
15         KEYWORDS=""
16         inherit git-r3
17         EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
18 else
19         KEYWORDS="~amd64 ~x86"
20         SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
21 fi
22
23 IUSE=""
24
25 DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
26                 dev-python/cython[${PYTHON_USEDEP}]
27                 >=sci-libs/fftw-3.3:3.0="
28 RDEPEND="${DEPEND}"