*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / ptyprocess / ptyprocess-0.5.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Run a subprocess in a pseudo terminal"
11 HOMEPAGE="https://github.com/pexpect/ptyprocess"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="ISC"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 sh sparc x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
21
22 python_test() {
23         py.test --verbose --verbose || die
24 }