*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / prompt_toolkit / prompt_toolkit-1.0.15.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Building powerful interactive command lines in Python"
11 HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
22         dev-python/wcwidth[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         test? ( dev-python/pytest[${PYTHON_USEDEP}] )
27 "
28
29 python_test() {
30         py.test || die
31 }