*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / promises / promises-2.0.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 MY_P=${PN%s}-${PV}
11
12 DESCRIPTION="An implementation of Promises in Python"
13 HOMEPAGE="https://github.com/syrusakbary/promise"
14 SRC_URI="https://github.com/syrusakbary/${PN%s}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
15
16 S=${WORKDIR}/${MY_P}
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21 IUSE=""
22
23 RDEPEND="
24         virtual/python-typing[${PYTHON_USEDEP}]
25         dev-python/six[${PYTHON_USEDEP}]
26 "
27
28 RESTRICT=test
29 # TODO: When we get all the dependencies in, we can add test
30 #       test? (
31 #               >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
32 #               dev-python/pytest-cov[${PYTHON_USEDEP}]
33 #               dev-python/coveralls[${PYTHON_USEDEP}]
34 #               dev-python/futures[${PYTHON_USEDEP}]
35 #               dev-python/pytest-benchmark[${PYTHON_USEDEP}]
36 #               dev-python/mock[${PYTHON_USEDEP}]
37 #       )
38
39 DEPEND="
40         dev-python/setuptools[${PYTHON_USEDEP}]
41 "