*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / process-tests / process-tests-2.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Tools for testing processes"
11 HOMEPAGE="https://github.com/ionelmc/python-process-tests https://pypi.org/project/process-tests/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
17
18 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 # There are no tests at all, under TODO
21 # see https://pypi.org/project/process-tests/2.0.2/
22 RESTRICT="test"
23
24 DOCS=( README.rst )